
Sign up to save your podcasts
Or


No internet, no networking; just a screen and a keyboard, or a pile of cards to punch holes in; mainframes were a world apart from today's smartphones and integrated circuits. Professor Brailsford remembers the Unix revolution.
To hear about the omission of Gnu and Richard Stallman: http://youtu.be/Wi326Leuemg
ICL computer photographs courtesy of couperus.org
ICL punch-card photographs courtesy of yesterdaystechnology.com
Professor Brailsford's discussion on the origin of Computer Science in academia http://youtu.be/uNuFVq5QeRk
http://www.facebook.com/computerphile
https://twitter.com/computer_phile
This video was filmed and edited by Sean Riley.
Computer Science at the University of Nottingham: http://bit.ly/nottscomputer
Computerphile is a sister project to Brady Haran's Numberphile. See the full list of Brady's video projects at:http://periodicvideos.blogspot.co.uk/...
Learn more about your ad choices. Visit megaphone.fm/adchoices
Fuzzing is a technique to find programming bugs by testing with random inputs - but there are smarter ways to go about it! Professor Alastair F Donaldson leads the Multicore Programming research group at Imperial College.
Computerphile is supported by Jane Street. Learn more about them (and exciting career opportunities) at: https://jane-st.co/computerphile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. More at https://www.bradyharanblog.com
Learn more about your ad choices. Visit megaphone.fm/adchoices
See how a Pick and Place robot works to complete a circuit board at Ciseco. Matt Lloyd takes us on a tour to illustrate how they design and make components and add-ons for the Raspberry Pi.
http://www.facebook.com/computerphile
https://twitter.com/computer_phile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. See the full list of Brady's video projects at:http://periodicvideos.blogspot.co.uk/...
Learn more about your ad choices. Visit megaphone.fm/adchoices
Continuing the deep dive down the network stack, Richard begins the story of TCP. Richard G Clegg is based at Queen Mary University London.
Next in the playlist: https://youtu.be/nKVML4YaBqs
RFC793 https://datatracker.ietf.org/doc/html/rfc793
RFC 9293 https://datatracker.ietf.org/doc/html/rfc9293
Computerphile is supported by Jane Street. Learn more about them (and exciting career opportunities) at: https://jane-st.co/computerphile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. More at https://www.bradyharanblog.com
Learn more about your ad choices. Visit megaphone.fm/adchoices
Surfing the web and Internet stacks.
Free audiobook: http://www.audible.com/computerphile
This video features Richard Mortier.
http://www.facebook.com/computerphile
https://twitter.com/computer_phile
This video was filmed and edited by Sean Riley.
Computer Science at the University of Nottingham: http://bit.ly/nottscomputer
Computerphile is a sister project to Brady Haran's Numberphile. See the full list of Brady's video projects at: http://bit.ly/bradychannels
Learn more about your ad choices. Visit megaphone.fm/adchoices
Network Basics story continues with the second part of the TCP segment. Richard G Clegg is based at Queen Mary University London.
Richard's Code: https://github.com/richardclegg/computerphile_demos/
RFC 5681 https://datatracker.ietf.org/doc/html/rfc5681
Computerphile is supported by Jane Street. Learn more about them (and exciting career opportunities) at: https://jane-st.co/computerphile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. More at https://www.bradyharanblog.com
Learn more about your ad choices. Visit megaphone.fm/adchoices
Elite was one of the first computer games to use 3d wireframe graphics and procedurally generated environments. Physicist Richard Hill shows us the game and explains how it inspired him.
Richard's first video about the BBC microcomputer: http://youtu.be/do6xydtcVPk
email your code to [email protected]
If you are interested in playing around with 'Aurena' check out Richard's University of Nottingham page here: http://www.nottingham.ac.uk/~ppzlev/
(or save this zip file and read the 'readme' file enclosed: http://www.nottingham.ac.uk/~ppzlev/aurena.zip )
http://www.facebook.com/computerphile
https://twitter.com/computer_phile
This video was filmed and edited by Brady Haran.
Computer Science at the University of Nottingham: http://bit.ly/nottscomputer
Computerphile is a sister project to Brady Haran's Numberphile. See the full list of Brady's video projects at:http://periodicvideos.blogspot.co.uk/...
Learn more about your ad choices. Visit megaphone.fm/adchoices
With the UK planning to follow Australia in a ban on social media for under 16s, we ask how it might work? Dr Mike Pound is an Associate Professor at the University of Nottingham.
Computerphile is supported by Jane Street. Learn more about them (and exciting career opportunities) at: https://jane-st.co/computerphile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. More at https://www.bradyharanblog.com
Learn more about your ad choices. Visit megaphone.fm/adchoices
What's the absolute minimum you can compress data to? - Entropy conjures up visions of chemistry and physics, but how does it apply to binary codes and computer science? Professor David Brailsford continues his discussion of compression.
Addendum: the formula at 4:40 is the "weighted average bits for that state"
rather than the total number of bits - (log^2)
Original Professor Brailsford film on compression: http://youtu.be/Lto-ajuqW3w
Professor Brailsford on Error Detection: http://youtu.be/-15nx57tbfc
http://www.facebook.com/computerphile
https://twitter.com/computer_phile
This video was filmed and edited by Sean Riley.
Computer Science at the University of Nottingham: http://bit.ly/nottscomputer
Computerphile is a sister project to Brady Haran's Numberphile. See the full list of Brady's video projects at:http://periodicvideos.blogspot.co.uk/...
Learn more about your ad choices. Visit megaphone.fm/adchoices
Clever Hans was a horse that could do maths, or was it using some other trick? Is AI music classification working like a 'Clever Hans?'
David Kelly is based at Kings College London. His paper is in preprint here: https://arxiv.org/pdf/2601.16675
Computerphile is supported by Jane Street. Learn more about them (and exciting career opportunities) at: https://jane-st.co/computerphile
This video was filmed and edited by Sean Riley.
Computerphile is a sister project to Brady Haran's Numberphile. More at https://www.bradyharanblog.com
Learn more about your ad choices. Visit megaphone.fm/adchoices
From the publisher's feed