
Sign up to save your podcasts
Or


Yes, it’s ULA! The IPv6 addressing sensation that’s sweeping the nation! Free at participating Internet standards bodies and ULA generating websites... Get yours today!
ULA contains a liquid core, which, if exposed due to rupture,should not be touched, inhaled, or looked at. Do not use ULA on dual-stacked networks. Discontinue use of ULA if any of the following occurs:
If ULA begins to smoke, get away immediately. ULA also may stick to certain types of skin.
When not in use, ULA should be returned to its special container and kept under refrigeration. The Ingredients of ULA include an unknown glowing green substance, which fell to Earth, presumably from outer space.
Do not taunt ULA.
ULA! Accept no substitutes!
RFC 4193
RFC 6724
RFC 3484
IPv6 Buzz
ULA is broken in dual-stacked networks
We’ve been busy! At least that’s our excuse. We recorded this episode with Dave Taht and Seth David Schoen about some new drafts they wrote for the Unicast Use of the Formerly Reserved address blocks such as 240.0.0.0, 127.0.0.0 and a few others, back in February. Needless to say, it was pretty interesting. Full of very polarizing topics (for oh-so-many reasons) this winding and wandering podcast lays out the history as well as the justifications for taking such address blocks - historically held as “untouchable” - and advocates for moving them into general use. Take a listen and decide for yourself!
The IPv4 Cleanup Project GitHub Repo
Original Bufferbloat MODEM episode with Dave
Is this a crossover episode? Ivan Pepelnjak of ipSpace.net and the SGW Podcast joins Chris Cummings and Nick Buraglio to discuss his latest project, netsim-tools! Tune in to learn about how Ivan has gone all-in on using Infrastructure as Code (IaC) prinicipals for building network labs with his latest project netsim-tools. This project lets you not only define your lab topology using a declarative syntax, but also removes the minutia of building a lab by pre-configuring all of the basics for you. Listen to learn more about all the juicy details!
Tune in to MODEM as Kevin Myers and Vince Schuele join Nick Buraglio and Chris Cummings to discuss their thoughts around the inaugural Networking Field Day Service Provider!
Once again we're behind on publishing! Recorded this episode with Kevin Myers right after the ZeroTier on RouterOS was released into the wild. We've had some drive time with it now, and we all believe one thing: it's worth your time. A lot of other greatness in here, LDPv6, IPv6 chatter, and delightful banter. Enjoy!
Off for the summer - after a short hiatus we're back!
Building large-scale network labs can be tedious and error prone—More importantly, they can be notoriously hard to spin up automatically. Containerlab is a new tool that promises to "redefine the way you run networking labs" and I really think it hits that target. On this episode of the Modulate Demodulate podcast, Nick and Chris C. are joined by Roman Dodin, one of the brains behind Containerlab.
Welcome back to the Modem podcast where we visit some of the dark and musty corners of the network and shine lights in pars of the network that many people haven’t touched before.
For many of us in main stream networking, we’re all about more. More bandwidth, more control. Bigger pipes. Faster switches etc… but there’s whole other spectrum that I’ve started to dive into over the last year that I wanted to bring to the table to discuss to prove that sometimes, more bandwidth isn’t the answer to everything, and that indeed, size matters, and sometimes, just sometimes, smaller is better.
Recently the smart home space has been abuzz when there suddenly appeared a new protocol on the scene that was all the new hotness called “Thread”.
Now like many protocols, it wasn’t really new at all, but was really just new to many of us who have never taken the time to dig into the interesting world of low-power low-data networking.
Luckily we have a special guest with us today to take by the hand and help us remember that everything in networking has it’s place. Even RIP.
In this episode, we welcome Jonathan Hui, CTO of the Thread Group to the show to take us down the rabbit whole into the history of this protocol, enlighten us to microverse of low-power/low-bandwidth networking, and help us remember that BGP isn’t the answer for everything.
Learn More about Thread
Thread Group Website
Thread Group Resources
Thread Networking Fundamentals
Connect on Social Media
Jonathan on Twitter
The Thread Group on Twitter
The Thread Group on LinkedIn
BGP is one of the most versatile routing protocols out there, but let's be honest—It kinda sucks when it comes to... Well, a lot of things. Specifically, there are a lot of issues with BGP's security (or lack thereof). BGP comes from a time when The Internet was much smaller and everyone knew everyone. Now that The Internet has exploded in growth, hijacks, both malicious and inadvertent, have required countless hours of pain-staking manual intervention and deep knowledge of BGP and the global routing table to diagnose—keeping your routes secure in this landscape almost seems like a sisyphean task.
Cue ARTEMIS. ARTEMIS (Automatic and Real-Time dEtection and MItigation System) does the hard work of detecting hijacks for you and it can even step in and attempt to mitigate them on your behalf. Okay, that sounds great, but how much does it cost? Nothing! ARTEMIS is free, open source, and even simple to install and use. Check out this episode of the Modulate Demodulate podcast as the lead developer for ARTEMIS and Co-founder/CTO of Code BGP, Vasileios Kotronis joins Chris C. and Nick to talk about the inner-workings of ARTEMIS.
ARTEMIS Live Demo
Route Views Project
ARTEMIS BGP Hijacking Survey with Network Operators Paper
Buffer Bloat. Most folks in the networking industry have at least heard this term, and may have a vague idea of what it means. It's certain that all of us have experienced it at one time or another - and likely thought it was a different problem. Over the last few years a couple of queuing disciplines have emerged that have allowed the users of the internet to experience fewer and fewer of those odd symptoms, and we wanted to know more about how those problems are getting solved. Fortunately, we managed to pin down Dave Täht and get him to talk to us about fq_codl and cake. Or so we thought. Turns out, that's a really, really big topic. Luckily, we had the expert to take time and really get down to the root of the problem, how it is solved, and give us a fantastic bit of history about how it came to be. This one has it all, folks. Boats, guitars, stickers, Dave even plays us a song at the end. It's a fun one, and the deep knowledge does not disappoint. Join me, Chris Cummings, Dan Siemon, and Dave Täht as we wander through the complex forest of buffer bloat, queuing codecs, and queue theory.
Bufferbloat and Beyond Book
Netstat command for looking at fq_codl:
Linux tc -s qdisc show dev eth0 netstat -c fq_codel -vvv
OSX
netstat -c fq_codel -vvv
Benchmarking fq_codel
SFQ, DRR, SQM, other queuing disciplines
The Flow Queue CoDel Packet Scheduler and Active Queue Management Algorithm
Photo:
From the publisher's feed