The Everything Feed - All Packet Pushers Pods

The Everything Feed - All Packet Pushers Pods

By Packet PushersTechnology
Download on the App Store

The Everything Feed - All Packet Pushers Pods episodes

  • PQ Show 81: Network Testing With ToDD
    If SDN is about automation and orchestration to configure the network, then the unasked (and unanswered question) is how do we test it? And how do we automate the testing?
    Recently, Matt Oswalt announced ToDD (Testing On Demand: Distributed), an open source tool for validating network changes.
    As Matt notes on his GitHub page, if you want to define the success of change, “…the only way to do that is to put your network through the same paces that the real-world does, and get detailed information back on how that test performed.”
    Matt joins us to talk about test-driven automation, and to share details about the ToDD project. Also joining the conversation is Chris Young, a networking professional who’s worked with a preview of ToDD.
    Links:
    The Power of Test-Driven Network Automation – Keeping It Classless
    Network Programmability and Automation by Jason Edelman; Scott S. Lowe; Matt Oswalt
    An Introduction To ToDD – Youtube
    Matt Oswalt’s Github page
    kontrolissues.net – Chris Young’s Blog
    Show Notes:
    Part 1: Test-Driven Network Automation

    * What does success look like?
    * Automation without verification says to me that speed is more important than consistency and predictability – and that’s just not the case in the real world.

    Part 2: ToDD

    * Concepts

    * Agents – runs the tests
    * Groups – defines which agents run the tests
    * Testruns – defines the tests
    * Testlets – standardizes the tests


    * Post-Test Analytics

    * InfluxDB
    * Graphana



    Part 3: Future of ToDD and TDNA

    * Maturation of ToDD itself

    * Vendor platforms


    * Maturation of rest of pipeline
    * Automated baselines (machine learning?)
    * We need to get better about not doing manual, bespoke things to our networks, including verification of changes. Automation without verification is pointless (and dangerous)

    0 min
  • PQ Show 80: P4 – A Language For Programming Switches
    P4 is a language for programming the forwarding plane of packet-processing devices such as switches right down to the chip level, allowing network operators to customize how a device processes packets.
    The goal of P4 is to enhance the flexibility of a network architecture and enable changes without having to wait for chip manufacturers or software developers to incorporate new features or protocol support.
    P4 is an open-source project under the Apache 2.0 license. The code is maintained by the P4 consortium, which was started by Nick McKeown at Stanford University and Jennifer Rexford at Princeton University.
    Our guest today to drill into the weeds about P4 is Professor McKeown. He’s been involved in several advances in networking technology over the last two decades. In particular, Nick has been a key driver of Software Defined Networking, and was a co-founder of Nicira Networks, which became VMware NSX. He is a full professor in Computer Science at Stanford University.
    Links:
    P4.org
    Let’s get started (A blog from Jennifer Rexford and Nick McKeown introducing P4)
    P4: Programming Protocol-Independent Packet Processors (Whitepaper)
    Programming Protocol-Independent Packet Processors (Slide presentation by Jennifer Rexford)

    0 min
  • PQ Show 79: Building The Digital Workplace With Aruba
    This episode of Priority Queue, sponsored by Aruba, a Hewlett Packard Enterprise company, explores the ongoing evolution of the digital workplace.
    As wireless networking has become both reliable and preferred by users, the next step is to fully utilize this network.
    The explosion of mobile and IoT devices are transforming the way we communicate and consume services. Mobility changes the very nature of our work environments, where collaborative open spaces and non-routine schedules are becoming the norm.
    Ozer Dondurmacioglu, Product Marketing Lead at Aruba, joins the Packet Pushers to talk about  how Aruba is helping IT networking teams can get ready for the digital workplace with the announcement of new products and solutions, including Aruba ClearPass for secure remote access.
    This podcast was recorded at the Aruba Atmosphere Conference in 2016.
    Links:
    Policy management with Aruba ClearPass
    Unified wired and wireless network infrastructure from Aruba
    Network management with Aruba AirWave
    Mobile engagement with Aruba Meridian
    Wi-Fi analytics with Aruba ALE
    0 min
  • Network Break 88: Cisco’s Big Quarter, Dell’s Debt Deal

    Take a Network Break! On today's episode we parse Cisco's latest quarterly earnings and future strategy, examine Dell's latest efforts to raise money for its EMC acquisition, and more.

    The post Network Break 88: Cisco’s Big Quarter, Dell’s Debt Deal appeared first on Packet Pushers.

    37 min
  • PQ Show 78: BGP Flowspec For DoS Mitigation
    Welcome to the Packet Pushers Priority Queue. On today’s show we’re going to talk about BGP flowspec, an RFC that can be used for DoS mitigation.
    But before we dive in, let’s level set on BGP, the border gateway protocol. BGP is the routing protocol that glues the Internet together. Big, huge companies and service providers use complex BGP policies to govern traffic flowing across their networks. BGP lets you perform some clever routing tricks that you can’t really do with an interior gateway routing protocol like OSPF or EIGRP.
    And all of that is, more or less, true. To quote RFC 4271, “The primary function of a BGP speaking system is to exchange network reachability information with other BGP systems.  This network reachability information includes information on the list of Autonomous Systems (ASes) that reachability information traverses. This information is sufficient for constructing a graph of AS connectivity for this reachability, from which routing loops may be pruned and, at the AS level, some policy decisions may be enforced.”
    Okay. So RFC 4271 tells us that BGP is, primarily for telling BGP speakers what networks are reachable via what autonomous systems. And if you dig a little deeper, you find that information is learned via the exchange of NLRIs – network layer reachability information messages.
    Now, here’s the big deal with BGP. An NLRI could contain any sort of information. An NLRI doesn’t have to contain an IP prefix with reachability information. You know, a route. For instance, RFC 4684 defines NLRIs that contain route-target information. RFC 4760 talks about NLRIs for multi-protocol BGP. RFC 7432 defines NLRIs for EVPN.
    Once you realize this, BGP becomes more than just a routing protocol. BGP can be used to share all sorts of information between BGP speakers to influence their forwarding decisions.
    The topic of our conversation today is RFC 5575, BGP flowspec. BGP flowspec defines a specific BGP NLRI defining a flow. What do BGP speakers do with this flow information?
    Our guest today is Justin Ryburn, who’s going to talk us through BGP flowspec and how it can be used to mitigate DoS and DDoS attacks.
    Justin is a Consulting Engineer with Juniper Networks. He’s been with Juniper for about 9 years in both pre-sales and post-sales Engineering roles, and has about 20 years experience in networking with a primary focus on service providers and carriers.
    Show Notes:
    Section 1 – Setting Up The problem: DoS Attacks

    * Briefly, what’s a DoS attack?

    * High Level – Denial of Service attack is any attack that denies (blocks) the legitimate use of a resource.
    * There is also a term DDoS. The extra D stands for distributed and it refers to the type of attack with a widely distributed source.


    * What are the chief ways DoS attacks are defended against (and their issues)?

    * Manual call – help me, I’m being attacked!
    * D/RTBH – victim announces RTBH
    * S/RTBH – victim calls for help, NOC initiates RTBH + uRPF


    * The big deal? Every flow dies in the blackhole in destination-based filtering. A lack of granularity that kills useful traffic along with the DoS traffic. Even source-based with uRPF is not a perfect answer, although it’s better that destination-based.

    * It is better in the sense that it does not “complete the attack” like you mentioned with destination-based filtering. However, it is impractical for a truly distributed attack as the source can be hundreds or thousands of hosts.



    Section 2 – Introducing BGP Flowspec For DoS Mitigation

    * What is BGP flowspec?

    0 min
  • Datanauts 033: Making Telemetry A Snap With Intel’s Open Framework

    On today's episode of Datanauts we learn about Snap, an open source telemetry framework to make collecting, processing, and publishing data center metrics modular, dynamic, and open. Snap was originally developed by Intel.

    The post Datanauts 033: Making Telemetry A Snap With Intel’s Open Framework appeared first on Packet Pushers.

    20 min
  • PQ Show 77: Location-Aware Apps With Aruba Meridian (Sponsored)
    This episode of Priority Queue, sponsored by Aruba, a Hewlett Packard Enterprise company, talks about location services. Location services are being deployed in shopping centers, stadiums, hospitals, and other public areas. They tap into wireless networks to enable people to get location-related information and services on their mobile devices.
    Traditional WLAN infrastructure is necessary for location services, but another key element is the Bluetooth Low Energy (BLE) protocol, which allows low-volume data transmissions over brief bursts instead of a continuous transmission.
    BLE has given rise to beacons – tiny Bluetooth devices that broadcasts a small amount of data at regular intervals. These beacons are so small that they can run on coin-sized batteries for 2 years.
    Placing beacons around a physical buildings allows smartphones to know where they are by hearing the BLE messages. By combining this with an app to fetch data based on the beacon and some programming, you can create location services.
    People can use their phones to find the shop they want in a large shopping mall, or get alerts that the person they want to meet is drinking coffee in the next room. Companies have new ways to generate revenue with push notifications to users.
    Julia Farina, Head of Product Marketing for Mobile Engagement at Aruba, sat down with Greg and Ethan at the Atmosphere 2016 conference to talk about location services and how the Aruba product line supports and enables these services.
    They discuss how BLE integrates with Aruba’s wireless infrastructure, examine use cases for location services, and dive into the Meridian platform for building location features into mobile applications.
    0 min
  • The Next Level: Mindfulness And IT Part 2
    In an previous episode of The Next Level we looked at the concept of mindfulness, its use for stress release and performance improvement, how mindfulness relates to IT, and whether the practice can (or should) be separated from its religious roots.
    On today’s episode we extend the discussion about the benefits of mindfulness in the context of an IT profession, including how it can improve interactions with colleagues, positively affect decision-making, and boost work performance.
    Our guest is Brian Harrington, IT Manager and podcaster. You can follow him on Twitter, and check out his podcasts Literally Figuratively Speaking (explicit content) and The Clecast.
    0 min
  • PQ Show 76: Understanding Aruba’s Unified Wired And Wireless Roadmap (Sponsored)
    Today’s Priority Queue show comes to you from Atmosphere 2016 Vegas – the largest community conference for enterprise mobility engineers – hosted by Aruba, a Hewlett Packard Enterprise company. Aruba has hit a $1 billion run rate for its mobility business since its acquisition by HPE, confirming the reasons behind the bold move.
    As the two organizations came together, campus and data center switching products were added to the Aruba portfolio of networking products as well, further increasing the total addressable market for the organization.
    Which brings us to the topic of today’s sponsored show with Aruba. The acquisition and the technology roadmap for the newly formed and unified networking organization cannot be viewed as simply as HPE Networking getting a new wireless LAN product line. There’s policy and management tools to consider. There’s some switching and wireless products that overlap — not everything can survive.
    Ethan Banks and Greg Ferro are joined by Michael Dickman, VP of Product Management for campus switching products at Aruba. Michael will give a detailed update regarding the progress on the integration roadmap and answer some key questions, including:
    What’s on the roadmap to integrate Aruba and HPE Networking product lines as they existed before the acquisition? What has been accomplished already? What does the unified wired and wireless networking portfolio look like?
    What are the leading software solutions for policy and network management? How is Aruba’s “mobile-first” campus and branch network architecture different from others in the networking industry? And how will the partner and customer relationships be affected? Join us to hear all about it.
    0 min
  • Infotrek Episode 3: Small Shop Design Part 1
    Small businesses are typically the step children of the IT world; they don’t receive enough attention from professionals and typically suffer from bad design practices.
    In this episode of Infotrek, your hosts join forces with guest Steven Sedory to talk about many of these bad practices and explore favorable alternatives for designing a good network for a small business.

    Your Hosts:
    John W Kerns is a network and systems engineer based in the Los Angeles/San Diego area. His background is in two traditionally stovepiped skill sets: systems administration and switching/routing/security. He spends most of his time as an implementation engineer for a medium sized VAR. Visit his blog at blog.packetsar.com or follow him on Twitter @PackeTsar.
    Derek Pocoroba is a Director of Enterprise Networking in the San Diego area. His background is heavy in enterprise networking and he holds CCIE #18559 Routing & Switching. Derek spends much of his time as a solutions architect, focusing on network architecture and design for his customers. Visit his blog on PacketPushers and LinkedIn or follow him on Twitter @dpocoroba.
    Mike Aossey is a Director of Practice Management in Orange County, CA. His background spans many different technologies in IT, but he focuses mostly on collaboration and programming. Mike oversees SMEs and architects VoIP solutions. Visit his blog on www.aossey.net or follow his rants on Twitter @aossey.
    Steven Sedory is a small business owner based out of Chino, California. His company, Vertical Computers, provides managed IT services, as well has VoIP and cloud hosting solutions. His background is in systems administration and small business systems architecture. Visit his website at verticalcomputers.com.
    Newsy News
    Windows 10 to include user-mode Ubuntu code with NT kernel. Native bash in Windows – InformationWeek
    Uber and DoD offer “bug bounties” to hackers who can find vulnerabilities – CNBC
    Oracle introduces “Cloud at Customer”. New trend for public cloud options? – InformationWeek
    Show Topic: Small Shop Design Part 1

    * Internet (Small or big pipe? Bigger if cloud is used a lot)
    * Core Networking (Stack, chassis, 10G?)
    * Wireless (Latest and greatest or just good enough?)
    * Identity Management (Just use Active Directory. Save the headache)

    0 min

About The Everything Feed - All Packet Pushers Pods

From the publisher's feed

Everything we offer in one high bandwidth output queue. New content every weekday. High priority, low latency, jitter free. Too much technology would never be enough.

More shows like The Everything Feed - All Packet Pushers Pods

Security Now (Audio) by TWiT

Security Now (Audio)

2,012 Listeners

Defensive Security Podcast - Malware, Hacking, Cyber Security & Infosec by Jerry Bell and Andrew Kalat

Defensive Security Podcast - Malware, Hacking, Cyber Security & Infosec

374 Listeners

Heavy Networking by Packet Pushers

Heavy Networking

327 Listeners

Risky Business by Risky Business Media

Risky Business

375 Listeners

The Fat Pipe - All Packet Pushers Pods by Packet Pushers

The Fat Pipe - All Packet Pushers Pods

70 Listeners

SANS Internet Stormcenter Daily Cyber Security Podcast (Stormcast) by Johannes B. Ullrich

SANS Internet Stormcenter Daily Cyber Security Podcast (Stormcast)

653 Listeners

Network Break by Packet Pushers

Network Break

101 Listeners

CyberWire Daily by N2K Networks

CyberWire Daily

1,029 Listeners

Smashing Security by Graham Cluley

Smashing Security

318 Listeners

Tech Bytes by Packet Pushers

Tech Bytes

5 Listeners

IPv6 Buzz by Packet Pushers

IPv6 Buzz

33 Listeners

Day Two DevOps by Packet Pushers

Day Two DevOps

15 Listeners

The Hedge by Russ White

The Hedge

18 Listeners

Cybersecurity Headlines by CISO Series

Cybersecurity Headlines

139 Listeners

Heavy Strategy by Packet Pushers

Heavy Strategy

27 Listeners

Risky Bulletin by Risky Business Media

Risky Bulletin

47 Listeners

Heavy Wireless by Packet Pushers

Heavy Wireless

11 Listeners

Packet Protector by Packet Pushers

Packet Protector

7 Listeners

Network Automation Nerds by Packet Pushers

Network Automation Nerds

5 Listeners

Total Network Operations by Packet Pushers

Total Network Operations

4 Listeners

Technically Leadership by Packet Pushers

Technically Leadership

0 Listeners

N Is For Networking by Packet Pushers

N Is For Networking

29 Listeners

The Cloud Gambit by Packet Pushers

The Cloud Gambit

0 Listeners

Life In Uptime by Packet Pushers

Life In Uptime

14 Listeners