
Sign up to save your podcasts
Or


Ever wanted to create a local development, without a lot of hassle? In this episode, I'm giving further insight in to the recent tutorial about building local development environments using Docker.
Docker is a tool that I — genuinely — have come to love, every bit as much as my enthusiasm in the episode shows.
If you've been having issues with setting up a local development environment, simply, quickly, and effectively, then this is an episode you don't want to miss.
For more information, check out the following links:
@zfmastery
Ever thought Eloquent and Expressive would go together like Ebony and Ivory?
I’m guessing the answer’s likely no. But, they can - if that’s your cup of tea, and you’re looking for a change from Zend\Db or Doctrine.
In this episode, I share why I decided to see if they’d fit in the recent tutorial.
For more information, check out the following links:
@zfmastery
In this episode, I give further background on the recent tutorial which covered the basics of downloading files in Zend Expressive.
Whilst downloading files can be a common part of creating web-based applications, people have mentioned that they’ve had trouble getting started doing so in Zend Expressive.
So I wanted to give yet more information, in addition to the tutorial, to help out.
Many thanks to @acelayaa and @haritk for the technical discussions and feedback.
For more information, check out the following links:
@zfmastery
Given Zend Framework’s design and very flexible nature, it can be easy to end up with a bloated global configuration, if we’re not careful. This episode follows up the recent tutorial on ConfigProviders.
In it, I provide further background the ConfigProviders tutorial, on why ConfigProviders can help reduce configuration complexity, and maintainability.
For more information, check out the following links:
@zfmastery
In this episode, I’m giving a quick overview of one of Zend Expressive’s two, non-default, routing packages - Aura Router. Part of the Aura project, which is an independent collection of libraries, and originally designed for PHP 5.4 by Paul M Jones (@pmjones). Aura is, in the words of the repository:
Powerful and flexible web routing for PSR-7 requests.
It's an excellent package, sporting a range of powerful features, including: route groups, route caching, custom matching rules, and the ability to generate paths from routes.
For more information, check out the following links:
@zfmastery
In this episode, I’m giving a quick overview of Zend Expressive’s default routing package - FastRoute. FastRoute, as the documentation says:
Provides a fast implementation of a regular expression based router
Written by Nikita Popov, or nikic on Twitter and GitHub, it’s both a simple and uncomplicated, yet extremely fast and highly performant routing package. It's one worthy of being the default routing package for the Zend Expressive standalone installer.
To find out more information on it, check out these key links:
@zfmastery
In this episode, I’m stepping through the standard directory structure, common to all Zend Expressive applications setup using the skeleton application and installer. It's a good discussion about what comes by default, and what each directory contains.
@zfmastery
With Zend Expressive, you can build all kinds of middleware-based applications, such as APIs, websites, single page applications, even extremely large and sophisticated applications.
In this episode, I show you four key ways in which you can configure your expressive applications.
These are:
To find out more information on it, check out these key links:
@zfmastery
In this episode I'm talking about a key benefit of PSR-7, one I hinted at in episode 2 & 3, one which I’m really excited about — interoperability.
Merriam-Webster defines interoperability as:
The ability of a system to work with or use the parts or equipment of another system
So why is that a good thing? Have a listen and find out.
In this episode, I’m looking at PSR-7, the second of two core components which Zend Expressive is built on. Zend Framework team lead, Matthew Weier O'Phinney describes it as:
a set of standard HTTP message interfaces so that we can create an ecosystem in which PHP developers can create re-usable middleware that they can share.
The PSR site describes it as:
common interfaces for representing HTTP messages as described in RFC 7230 and RFC 7231, and URIs for use with HTTP messages as described in RFC 3986.
To find out more information on it, check out these key links:
@zfmastery
From the publisher's feed