The Backend Engineering Show with Hussein Nasser

The Backend Engineering Show with Hussein Nasser

By Hussein NasserTechnology
Download on the App Store

The Backend Engineering Show with Hussein Nasser episodes

  • MongoDB Internal Architecture | The Backend Engineering Show

    I’m a big believer that database systems share similar core fundamentals at their storage layer and understanding them allows one to compare different DBMS objectively. For example, How documents are stored in MongoDB is no different from how MySQL or PostgreSQL store rows. Everything goes to disk, the trick is to fetch what you need from disk efficiently with as fewer I/Os as possible, the rest is API.  In this video I discuss the evolution of MongoDB internal architecture on how documents are stored and retrieved focusing on the index storage representation. I assume the reader is well versed with fundamentals of database engineering such as indexes, B+Trees, data files, WAL etc, you may pick up my database course to learn the skills. Let us get started.



    Fundamentals of Backend Engineering Design patterns udemy course (link redirects to udemy with coupon) https://backend.husseinnasser.com Fundamentals of Networking for Effective Backends udemy course (link redirects to udemy with coupon) https://network.husseinnasser.com Fundamentals of Database Engineering udemy course (link redirects to udemy with coupon) https://database.husseinnasser.com



    45 min
  • How UI/UX can break the backend

    The User Interface/User Experience has great impact on the backend architecture and scalability. In this podcast I discuss three UI/UX that affected backend design and scalability.

    0:00 Intro

    1:40 UI vs UX

    4:30 Google Chrome OmniBox

    12:30 1 out of X Page

    20:00 YouTube Notification

    Resources

    https://blog.apnic.net/2020/08/21/chromiums-impact-on-root-dns-traffic/

    Fundamentals of Backend Engineering Design patterns udemy course (link redirects to udemy with coupon)

    https://backend.husseinnasser.com

    31 min
  • Do DHCP and DNS Servers Communicate?

    In this video I explain how DHCP work and how it updates DNS entries for new hosts joining the network. I'll also mention Zero Config

    0:00 Intro

    1:00 the Network configuration

    6:00 Showing DHCP in Wireshark

    6:30 DHCP Discover

    14:40 DHCP Offer

    19:00 DHCP Request

    21:30 DHCP ACK

    22:00 How DHCP Updates DNS

    26:15 Zero Configuration (mDNS, Link-local)

    Resources

    Dhcp https://datatracker.ietf.org/doc/html/rfc1541

    Dynamic updates , dhcp RFC2136

    https://datatracker.ietf.org/doc/html/rfc2136

    https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/xe-3se/3850/dhcp-xe-3se-3850-book/dhcp-client-option-12.pdf

    RFC 1497

    https://www.rfc-editor.org/rfc/rfc1497.html

    https://www.rfc-editor.org/rfc/rfc6762#ref-Zeroconf

    Link-local

    https://www.rfc-editor.org/rfc/rfc3927

    31 min
  • Compressing Certificates in TLS | The Backend Engineering Show
    Fundamentals of Backend Engineering Design patterns udemy course (link redirects to udemy with coupon)
    https://backend.husseinnasser.com
    Certificates provide a way to authenticate both the server and the client and are included as part of the TLS handshake. However, the certificates can be large because the full certificate chain is included in the handshake. The large certificates can go up to 10KB in size and take multiple segments to deliver and assemble. RFC 8879 discusses how TLS compression can be achieved, I discuss that in this podcast. Enjoy.
    0:00 Intro
    4:15 Certificate Chain
    6:00 Faking the chain
    8:50 Certificate Stores
    10:30 Including ROOT cert in the chain
    12:00 The performance penalty of large certificate chain
    20:15 RFC 8879 TLS Certificate Compression
    23:00 How Compression Works in TLS 1.2 vs TLS 1.3
    30:30 What could go wrong?
    Resources
    https://datatracker.ietf.org/doc/rfc8879/
    https://www.rfc-editor.org/rfc/rfc5246
    https://www.rfc-editor.org/rfc/rfc6928.html
    35 min
  • When NodeJS I/O Blocks | The Backend Engineering Show

    In this episode of the backend engineering show I go through an article I wrote discussing NodeJS Asynchronous I/O

    https://medium.com/@hnasr/when-nodejs-i-o-blocks-327f8a36fbd4

    Learn the fundamentals of network engineering, get my udemy course

    https://network.husseinnasser.com


    Buy me a coffee if you liked this 

    https://www.buymeacoffee.com/hnasr



    0:00

    3:00 Part 1 Socket/IO

    9:48 Part 2 File I/O

    12:42 Part 3 DNS

    16:22 Part 4 NodeJS Single Threaded

    19:10 Part 5 NodeJS Thread Pool

    21:23 Part 6 DNS lookup bottleneck in Node

    26 min
  • NGINX Internal Architecture - Workers | The Backend Engineering Show

    Buy me a coffee if you liked this https://www.buymeacoffee.com/hnasr

    In this podcast I explain the NGINX internal process architecture, how NGINX spins up multiple processes per core, how each process is pinned to a CPU core for minimum context switching,  how NGINX accepts connections , parses requests and talks to the backend.   Get my introduction to NGINX udemy course  https://nginx.husseinnasser.com

    16 min
  • Cloudflare is moving away from NGINX | The Backend Engineering Show
    Cloudflare identified several limitations in NGINX architecture and decided to write their own reverse proxy.
    0:00 Intro
    1:53 What NGINX is used for
    3:37 NGINX Architecture
    7:52 NGINX Limitations
    17:12 Cloudflare Pingora
    Buy me a coffee if you liked this
    https://www.buymeacoffee.com/hnasr
    Fundamentals of Networking for Effective Backends udemy course (link redirects to udemy with coupon)
    https://network.husseinnasser.com
    Fundamentals of Database Engineering udemy course (link redirects to udemy with coupon)
    https://database.husseinnasser.com
    Introduction to NGINX (link redirects to udemy with coupon)
    https://nginx.husseinnasser.com
    Python on the Backend (link redirects to udemy with coupon)
    https://python.husseinnasser.com
    Become a Member on YouTube
    https://www.youtube.com/channel/UC_ML5xP23TOWKUcc-oAE_Eg/join
    Resources Resources:
    https://blog.cloudflare.com/how-we-built-pingora-the-proxy-that-connects-cloudflare-to-the-internet/
    https://www.nginx.com/blog/socket-sharding-nginx-release-1-9-1/amp/
    27 min
  • Threads and Connections | The Backend Engineering Show
    In this episode of the backend engineering show I discuss the evolution of multi-threading apps, their pros and cons and then I go through 5 threading model and how they interleave with backend connection management between the threads and requests handlings. Enjoy
    To learn more about networking fundamentals check out my udemy course Fundamentals of Networking for Effective Backends Head to https://network.husseinnasser.com for a discount coupon
    0:00 Intro
    2:00 Single Threading
    6:30 Multi-Threading
    14:15 Connection Listener
    20:15 How Connections are Established
    29:00 Single Listener/Worker thread
    33:30 Single Listener, Multiple Worker threads
    39:00 Single Listener, Multiple Workers with load balancing
    42:10 Multiple Listeners on the same port (SO_REUSEPORT)
    45:20 Multiple Single Threaded Backend
    Buy me a coffee https://www.buymeacoffee.com/hnasr
    51 min

About The Backend Engineering Show with Hussein Nasser

From the publisher's feed

Welcome to the Backend Engineering Show podcast with your host Hussein Nasser. If you like software engineering you’ve come to the right place. I discuss all sorts of software engineering technologies and news with specific focus on the backend. All opinions are my own.

More shows like The Backend Engineering Show with Hussein Nasser

Freakonomics Radio by Freakonomics Radio + Stitcher

Freakonomics Radio

31,921 Listeners

Software Engineering Radio - the podcast for professional software developers by team@se-radio.net (SE-Radio Team)

Software Engineering Radio - the podcast for professional software developers

274 Listeners

Risky Business by Risky Business Media

Risky Business

373 Listeners

Science Vs by Spotify Studios

Science Vs

12,154 Listeners

Syntax - Tasty Web Development Treats by Wes Bos & Scott Tolinski - Full Stack JavaScript Web Developers

Syntax - Tasty Web Development Treats

987 Listeners

Darknet Diaries by Jack Rhysider

Darknet Diaries

8,077 Listeners

Practical AI by Daniel Whitenack and Chris Benson

Practical AI

210 Listeners

Within Reason by Alex J O'Connor

Within Reason

1,628 Listeners

All-In with Chamath, Jason, Sacks & Friedberg by All-In Podcast, LLC

All-In with Chamath, Jason, Sacks & Friedberg

10,107 Listeners

Dwarkesh Podcast by Dwarkesh Patel

Dwarkesh Podcast

550 Listeners

Big Technology Podcast by Alex Kantrowitz

Big Technology Podcast

512 Listeners

Hard Fork by The New York Times

Hard Fork

5,561 Listeners

The AI Daily Brief: Artificial Intelligence News and Analysis by Nathaniel Whittemore

The AI Daily Brief: Artificial Intelligence News and Analysis

670 Listeners

Prof G Markets by Vox Media Podcast Network

Prof G Markets

1,440 Listeners

The Pragmatic Engineer by Gergely Orosz

The Pragmatic Engineer

74 Listeners