Request for Comments

Request for Comments

By Anna-Lena BaeckerTechnologyEducation
Download on the App Store

Request for Comments episodes

  • RFCE009: IP Routing I

    Ein Jahr RFC Podcast und zum Jubiläum haben Clemens und ich es echt nochmal geschafft eine Sendung aufzunehmen. Es geht um Routing und der Themenumfang musste ganz diszipliniert auf die Grundlagen reduziert werden. Es empfiehlt sich, die bisherigen Folgen zu IPv4 und ICMP sowie Ethernet und Switching I und die Folgesendung II vorher gehört zu haben oder dann bei Gelegenheit nach zuhören.

    Vielen Dank an alle Hörer*innen und Gäste für ein schönes Jahr mit “Request for Comments”! Besonderen Dank gebührt denjenigen, die mich Anfang 2016 zum ‘selber machen’ überredet haben – es macht mir auch immer noch viel Spaß.

    • Anna-Lena
      • AnnLe
      • Paypal
      • Flattr
      • Amazon Wishlist
      • Clemens Schrimpe
        • Twitter
        • podseed.org
          • Twitter
          • Paypal
          • Flattr
            Feed
            Enclosure
            Request for Comments (Request for Comments (MPEG-4 AAC Audio))
            MPEG-4 AAC Audio
            Request for Comments (Request for Comments (MP3 Audio))
            MP3 Audio
            Request for Comments (Request for Comments (Opus Audio))
            Opus Audio
            Request for Comments (Request for Comments (Ogg Vorbis Audio))
            Ogg Vorbis Audio

            [shownotes mode=”block”]

            3 hr 37 min
          • RFCE008: Deflate Compressed Data Format Specification

            Auf dem 33c3 habe ich die Gelegenheit genutzt und mich mit Michael Steil über RFC1951  unterhalten. Verlustfreies Kleinrechnen von Daten mit diesem Algorithmus kennen wir alle aus zip-Dateien. Wie genau das funktioniert, erklärt Michael per “Glücksrad” und dem “E wie Ernstl”.

            An Tag 4 des diesjährigen Congresses hält Michael zudem noch den ultimativen Gameboy Talk, den ich euch wärmstens empfehlen möchte. Diesmal keine Kapitelmarken. Shownotes ergänze ich nach dem Congress.

            • Anna-Lena
              • AnnLe
              • Paypal
              • Flattr
              • Amazon Wishlist
              • Michael Steil
                • Twitter
                • podseed.org
                  • Twitter
                  • Paypal
                  • Flattr
                    Feed
                    Enclosure
                    Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                    MPEG-4 AAC Audio
                    Request for Comments (Request for Comments (MP3 Audio))
                    MP3 Audio
                    Request for Comments (Request for Comments (Opus Audio))
                    Opus Audio
                    Request for Comments (Request for Comments (Ogg Vorbis Audio))
                    Ogg Vorbis Audio

                    [shownotes mode=”block”]

                     

                    1 hr 7 min
                  • RFCE007: ietf 96 Special II - Network Operations Center [English]

                    This is the second part of the #ietf96 special and recorded in English. My guest is Clemens Schrimpe. Clemens has been a volunteer to the NOC Team at IETF for many years, as you might already know if you are a frequent listener of this podcast or freakshow. Clemens talks about how the NOC Team sets up the ietf-network and how they bring “the internet” to meeting facilities all over the world. The topics contain timelines, logistics and how the hotel network becomes part of the ietf-net. And of course, me fangirling around.

                    Shownotes

                    IETF NOC Team Volunteers:

                    •  Hirochika Asai (The University of Tokyo/WIDE)
                    •  Randy Bush (IIJ)
                    •  Joe Clarke (Cisco)
                    •  Colin Doyle (Right! Systems Inc)
                    •  Bill Fenner (Arista)
                    •  Joel Jaeggli (Fastly)
                    •  Bill Jensen (University of Wisconsin–Madison)
                    •  Hans Kuhn (NSRC)
                    •  Warren Kumari (Google)
                    •  Lucy Lynch (NSRC)
                    •  Jim Martin (INOC)
                    •  Rob Nagy (DeepDive Networking)
                    •  Karen O’Donoghue (ISOC)
                    •  Clemens Schrimpe

                    [shownotes mode=”block”]

                    • Anna-Lena
                      • AnnLe
                      • Paypal
                      • Flattr
                      • Amazon Wishlist
                      • Clemens Schrimpe
                        • Twitter
                        • podseed.org
                          • Twitter
                          • Paypal
                          • Flattr

                             

                            3 hr 43 min
                          • RFCE006: ietf 96 Special I - RIPE

                            Ich war auf einem ietf-Meeting in Berlin – und es war fantastisch. Herausgekommen sind ein paar sehr interessante Interviews, die ich mit tollen Menschen führen konnte. Einer davon ist Daniel Karrenberg, ein Internet-Mensch der ersten Stunde. Als erster Director des Ripe NCC hat er eine Menge zu berichten und ich freue mich sehr, dass ich mich mit ihm über Geschichte und Zusammenhänge von RIPE, RIPE NCC, ietf, ISOC und ICANN  unterhalten konnte.

                            Freut euch auf die erste Folge zum ietf96-Special: RIPE und ich möchte euch das RIPE Atlas Projekt sehr ans Herz legen, das ebenfalls Thema im Interview sein wird. Meine Probe sendet bereits brav. Ergänzungen zu den Shownotes nehme ich übrigens wirklich gerne entgegen – die machen nämlich recht viel Arbeit und sind daher sicher nicht vollständig.

                            The podcast ‘request for comments’ does not speak for the ietf.

                            • Anna-Lena
                              • AnnLe
                              • Paypal
                              • Flattr
                              • Amazon Wishlist
                                Feed
                                Enclosure
                                Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                MPEG-4 AAC Audio
                                Request for Comments (Request for Comments (MP3 Audio))
                                MP3 Audio
                                Request for Comments (Request for Comments (Opus Audio))
                                Opus Audio
                                Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                Ogg Vorbis Audio

                                [shownotes mode=”block”]

                                1 hr 50 min
                              • RFCE005: TCP Grundlagen

                                Ja, es hat viel zu lange gedauert. Erst gab es Terminschwierigkeiten, dann hatte ich kein Internet und dann wieder Terminschwierigkeiten. Aber wir haben es geschafft und ich hoffe, ihr freut euch auf die TCP Grundlagen in dieser Episode. Ich bin bei der Aufnahme leider noch merklich angeschlagen, aber durch meinen fantastischen Gast fällt das kaum noch auf: Diesmal ist nämlich Andreas Bogk zu Gast und wir gehen in der bisher kürzesten Folge diszipliniert durch die Grundlagen des Transmission Control Protocols, RFC 793. Die Protokollfamilie aus Episode 1, IPv4 und ICMP, ist nun mit TCP komplettiert.

                                Für diese Episode empfehle ich euch sehr, die Grafiken aus Kapitel 3.1 RFC 793 zur Hand zu haben. Wir schauen uns zunächst wieder den Header an, bevor wir dann mit dem ersten SYN Kontakt aufnehmen und mit FIN wieder beenden.

                                Viel Vergnügen!

                                TCP Header

                                State diagram

                                • Anna-Lena
                                  • AnnLe
                                  • Paypal
                                  • Flattr
                                  • Amazon Wishlist
                                  • Andreas Bogk
                                    • Twitter
                                    • podseed.org
                                      • Twitter
                                      • Paypal
                                      • Flattr
                                        Feed
                                        Enclosure
                                        Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                        MPEG-4 AAC Audio
                                        Request for Comments (Request for Comments (MP3 Audio))
                                        MP3 Audio
                                        Request for Comments (Request for Comments (Opus Audio))
                                        Opus Audio
                                        Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                        Ogg Vorbis Audio

                                        [shownotes mode=”block”]

                                        1 hr 35 min
                                      • RFCE004: IEEE statt RFC II

                                        Lange hat es gedauert und dann muss ich noch die Shownotes nachliefern, aber der Teil II der Sondersendung zu Ethernet und Switching mit dem “coolen Teil” ist da. Neben dem  persönlichen Debugging meiner Netzwerkstolperfallen geht es um Link Aggregation, Trunking, Stacking und VLANS. Während Clemens derzeit in Buenos Aires mit am Netz für die ietf schraubt, erzählt er im Podcast wie er seine Switches auf Veranstaltungen am liebsten miteinander sprechen lässt. Viel Spaß dabei!

                                        Es gab beim zweiten Teil der Aufnahme ziemlich heftige technische Probleme, hoffe aber sie alle erwischt zu haben.

                                        podseed.org ist weiterhin eine Spende wert, denn von dort ladet ihr die Episoden runter. :)

                                        • Anna-Lena
                                          • AnnLe
                                          • Paypal
                                          • Flattr
                                          • Amazon Wishlist
                                          • Clemens Schrimpe
                                            • Twitter
                                              Feed
                                              Enclosure
                                              Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                              MPEG-4 AAC Audio
                                              Request for Comments (Request for Comments (MP3 Audio))
                                              MP3 Audio
                                              Request for Comments (Request for Comments (Opus Audio))
                                              Opus Audio
                                              Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                              Ogg Vorbis Audio
                                              2 hr 22 min
                                            • RFCE003: IEEE statt RFC I
                                              Intensivkurs Layer 2: Ethernet und Switching

                                              Nach einer etwas längeren Pause habe ich mich mal wieder ausgiebig mit Clemens unterhalten. Nachdem wir in RFCE001 mit IPv4 auf Layer 3 eingestiegen sind, geht es nochmal eine Etage tiefer. Kein RFC, sondern IEEE 802.3 steht im Fokus der Sendung.

                                              Da es wieder so viel zu erzählen gab und es in der episch langen Aufnahme zum Ende hin technische Schwierigkeiten gab, sind es gleich zwei Folgen geworden. In Teil 1 fangen wir mal mit Ethernetframes, Netzwerktopologie und der Funktionsweise von Switches an. Das Konzept der Control- und Data-Plane bis zum Spanning Tree sind dann Voraussetzung für die nächste Folge.

                                              Hörer*innentreffen?

                                              Wir sinnieren außerdem über Hörer*innen Diskussionsrunden oder einfach ein nettes Treffen. Die rpTEN vom 02.-04. Mai 2016 in Berlin würde sich anbieten. Vorausgesetzt, Clemens kann seine Core Switches und Router kurz alleine lassen. Schreibt dazu auch gerne mal in die Kommentare damit ich abschätzen kann, ob wir überhaupt eine anwesende Hörer*innen-Base mit Interesse hätten. In den Kommentaren freue ich mich  aber natürlich auch sonst über Feedback.

                                              Ich möchte euch übrigens noch auf podseed.org aufmerksam machen, die so lieb waren Request for Comments von Anfang an zu unterstützen. Vielen Dank dafür und ihr dürft euch auch gerne bedanken. :)

                                              • Anna-Lena
                                                • AnnLe
                                                • Paypal
                                                • Flattr
                                                • Amazon Wishlist
                                                • Clemens Schrimpe
                                                  • Twitter
                                                  • podseed.org
                                                    • Twitter
                                                    • Paypal
                                                    • Flattr
                                                      Feed
                                                      Enclosure
                                                      Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                                      MPEG-4 AAC Audio
                                                      Request for Comments (Request for Comments (MP3 Audio))
                                                      MP3 Audio
                                                      Request for Comments (Request for Comments (Opus Audio))
                                                      Opus Audio
                                                      Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                                      Ogg Vorbis Audio

                                                      Shownotes

                                                      Intro: Spanning Tree Song  
                                                      [shownotes mode=”block”]

                                                      2 hr 18 min
                                                    • RFCE002: UDP und NAT-PMP

                                                      In Episode zwei nehmen wir eine andere Perspektive ein und betrachten Netzwerke aus der Sicht des Application Developments. Mein Gast ist Dom und wir unterhalten uns erst einmal über den dreiseitigen RFC 768, also UDP. Wie man in einem Netzwerk freundlich kommuniziert, erklärt Dom dann am Beispiel des UDP-basierten NAT-PMP (NAT-Port Mapping Protocol). Der Informational RFC 6886 ist ein Beispiel für ein simples Protokoll, das sich durch einen rücksichtsvollen Umgang mit begrenzten Ressourcen in einem Heimnetzwerk auszeichnet und von dem man einiges lernen kann. Das dachte man sich wohl auch, als man mit dem Standard RFC 6887 auf NAT-PMP aufsetzte und diesen erweiterte.

                                                      Zwei Stunden kürzer und wieder ein anderes Audio Setup. Wird aber. Vielen Dank für das Feedback zur ersten Folge!

                                                      • Dom
                                                        • Twitter
                                                        • Anna-Lena
                                                          • AnnLe
                                                          • Paypal
                                                          • Flattr
                                                          • Amazon Wishlist

                                                            Feed
                                                            Enclosure
                                                            Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                                            MPEG-4 AAC Audio
                                                            Request for Comments (Request for Comments (MP3 Audio))
                                                            MP3 Audio
                                                            Request for Comments (Request for Comments (Opus Audio))
                                                            Opus Audio
                                                            Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                                            Ogg Vorbis Audio

                                                            Shownotes

                                                            [shownotes mode=”block”]

                                                            1 hr 52 min
                                                          • RFCE001: IPv4 und ICMP

                                                            In der ersten Folge habe ich mich ausführlich mit meinem Gast Clemens Schrimpe über RFC 791 (IPv4) unterhalten. Nach einem Überblick zu RFC allgemein, zerpflücken wir den IPv4 Header in seine Bits, Nibble und Bytes und vergessen dabei im Eifer die ‘Optionsfelder’. Das haben wir später remote nachgeholt, so dass am Ende der Folge auch der Header vollständig ist. Da RFC 791 ohne RFC 792 nicht so richtig komplett ist, haben wir uns zusätzlich ICMP vorgenommen. Wir schrammen noch ein Stück RFC 826 und beenden die erste Sendung nach knapp vier Stunden. Ich wünsche euch viel Spaß!

                                                            ‘Request for Comments’ dürft ihr gerne wörtlich nehmen. Ich freue mich über Feedback.

                                                            Vorweg: Es gibt nur ein Outtake als Intro und der Start ist insgesamt etwas holprig. Die Remote Aufnahme könnte besser und Kapitelmarken funktionieren nur vielleicht. :)

                                                            • Clemens Schrimpe
                                                              • Twitter
                                                              • Anna-Lena
                                                                • AnnLe
                                                                • Paypal
                                                                • Flattr
                                                                • Amazon Wishlist

                                                                  Feed
                                                                  Enclosure
                                                                  Request for Comments (Request for Comments (MPEG-4 AAC Audio))
                                                                  MPEG-4 AAC Audio
                                                                  Request for Comments (Request for Comments (MP3 Audio))
                                                                  MP3 Audio
                                                                  Request for Comments (Request for Comments (Opus Audio))
                                                                  Opus Audio
                                                                  Request for Comments (Request for Comments (Ogg Vorbis Audio))
                                                                  Ogg Vorbis Audio

                                                                  [shownotes mode=”block”]

                                                                  3 hr 54 min
                                                                • RFCE000: Die Nullnummer

                                                                  RFC definieren das Internet. Nahezu jeder Informationsaustausch zwischen zwei Rechnern verläuft über Protokolle, die einmal durch einen Request for Comments definiert und standardisiert wurden. Genug Material, um darüber zu reden.

                                                                  Mit wechselnden Gesprächspartner*innen rede ich hier bald über die Standards, auf denen unsere tägliche Kommunikation beruht.

                                                                  Viel Spaß bei der Nullnummer von Request for Comments!


                                                                  • Anna-Lena
                                                                    • AnnLe
                                                                    • Paypal
                                                                    • Flattr
                                                                    • Amazon Wishlist

                                                                      10 min

                                                                    About Request for Comments

                                                                    From the publisher's feed

                                                                    Gespräche über RFC

                                                                    More shows like Request for Comments

                                                                    Bits und so by Undsoversum GmbH

                                                                    Bits und so

                                                                    25 Listeners

                                                                    Streitkräfte und Strategien by NDR

                                                                    Streitkräfte und Strategien

                                                                    45 Listeners

                                                                    Freak Show by Metaebene Personal Media - Tim Pritlove

                                                                    Freak Show

                                                                    9 Listeners

                                                                    Apfelfunk by Malte Kirchner & Jean-Claude Frick

                                                                    Apfelfunk

                                                                    7 Listeners

                                                                    c’t uplink - der IT-Podcast aus Nerdistan by c’t Magazin

                                                                    c’t uplink - der IT-Podcast aus Nerdistan

                                                                    8 Listeners

                                                                    heiseshow by heise online

                                                                    heiseshow

                                                                    3 Listeners

                                                                    Logbuch:Netzpolitik by Metaebene Personal Media - Tim Pritlove

                                                                    Logbuch:Netzpolitik

                                                                    5 Listeners

                                                                    UKW by Metaebene Personal Media - Tim Pritlove

                                                                    UKW

                                                                    1 Listeners

                                                                    Baywatch Berlin by Klaas Heufer-Umlauf, Thomas Schmitt, Jakob Lundt & Studio Bummens

                                                                    Baywatch Berlin

                                                                    75 Listeners

                                                                    Mac & i - der Apple-Podcast by Mac & i

                                                                    Mac & i - der Apple-Podcast

                                                                    0 Listeners

                                                                    Bit-Rauschen: Der Prozessor-Podcast von c’t by c't Magazin

                                                                    Bit-Rauschen: Der Prozessor-Podcast von c’t

                                                                    0 Listeners

                                                                    Machtwechsel by Dagmar Rosenfeld und Robin Alexander

                                                                    Machtwechsel

                                                                    102 Listeners

                                                                    Politik mit Anne Will by Anne Will

                                                                    Politik mit Anne Will

                                                                    32 Listeners

                                                                    Passwort - der Podcast von heise security by Dr. Christopher Kunz, Sylvester Tremmel

                                                                    Passwort - der Podcast von heise security

                                                                    3 Listeners

                                                                    Fest & Flauschig by Jan Böhmermann & Olli Schulz

                                                                    Fest & Flauschig

                                                                    18 Listeners